Schoology Performance - Intermittent Errors
Incident Report for PowerSchool Products
Resolved
This incident has been resolved.
Posted Sep 28, 2022 - 10:24 PDT
Monitoring
Customers may have experienced intermittent access to Schoology. We are currently monitoring the site to ensure availability for customers. Thank you for your patience.
Posted Sep 28, 2022 - 09:32 PDT
This incident affected: Schoology (Schoology).