eSchool Multi-Tenant East is currently down.
Incident Report for PowerSchool Products
Resolved
This incident has been resolved.
Posted Oct 16, 2024 - 04:45 PDT
Investigating
We are currently investigating this issue.
Posted Oct 15, 2024 - 14:40 PDT
This incident affected: PowerSchool eSchoolPlus SIS.