BusinessPlus users encountering errors when logging into BusinessPlus

Incident Report for PowerSchool Products

Resolved

This incident has been resolved.
Posted May 18, 2026 - 11:52 PDT

Monitoring

Service has been restored and we are monitoring for continued stability.
Posted May 18, 2026 - 10:33 PDT

Investigating

We are currently investigating reports of users encountering errors when attempting to log in to BusinessPlus.
Posted May 18, 2026 - 10:20 PDT
This incident affected: BusinessPlus.