PowerBuddy for Data Analysis (PBDA) is down

Incident Report for PowerSchool Products

Resolved

The issue reported for PowerBuddy for Data Analysis (PBDA) has been resolved and this incident has been closed.
Posted Sep 04, 2025 - 17:40 PDT

Investigating

PowerSchool is aware of an issue where the PowerBuddy for Data Analysis (PBDA) is down. We are currently investigating the issue and will provide updates when available. If you are experiencing an outage, please submit a ticket to the support team.
Posted Sep 04, 2025 - 15:51 PDT
This incident affected: Connected Intelligence K-12.