Extreme weather conditions in British Columbia may impact access to Atrieve
Incident Report for PowerSchool Products
Resolved
This incident has been resolved.
Posted Dec 02, 2021 - 14:13 PST
Update
We are continuing to monitor for any further issues.
Posted Nov 16, 2021 - 09:15 PST
Monitoring
Due to severe weather conditions in British Columbia, our network service providers are reporting that customers are experiencing slow network speeds and congestion throughout British Columbia, where our western Canadian hosting operations reside.

We are working with our service providers to monitor any issues. We want to alert you in case users are experiencing performance degradation due to this extreme weather event. Thank you for your patience and understanding on this matter.
Posted Nov 16, 2021 - 09:15 PST
This incident affected: Atrieve (HOST02, HOST03, HOST04, HOST05, HOST06, HOST07, HOST08, HOST11, HOST12).