PowerSchool SIS - Service Interruption
Incident Report for PowerSchool Products
Resolved
We are pleased to inform you that the systems have been fully restored and are now back to normal operations. All services are operating as expected. We apologize for any inconvenience this may have caused and thank you for your patience and understanding during this time. If you experience any further issues, please do not hesitate to contact our support team.
Posted Jul 22, 2024 - 08:19 PDT
Update
All PowerSchool SIS customers should now have access to their PowerSchool SIS application.

We are continuing to monitor for any further issues.
Posted Jul 20, 2024 - 09:37 PDT
Monitoring
Currently Central, West and Canadian regions have been brought back online after being impacted by the Microsoft Global Outage. We continue to restore service to East region and will provide updates as they become available. We appreciate your patience while we work to resolve this issue.
Posted Jul 20, 2024 - 04:00 PDT
Identified
PowerSchool SIS is currently being impacted by the Microsoft Global Outage. We will provide updates here as they become available.
Posted Jul 19, 2024 - 05:15 PDT
Investigating
We are aware of a service interruption with PowerSchool SIS. We are working to assess the situation and will provide you with regular updates as they become available. We appreciate your patience while we work to resolve this issue.
Posted Jul 19, 2024 - 05:10 PDT
This incident affected: PowerSchool SIS.