Unified Classroom - Login Service Disruption
Incident Report for PowerSchool Products
Resolved
We worked diligently and full functionality was restored to Unified Classroom. We apologize for any inconvenience this may have caused and appreciate your patience while we worked to resolve these issues. We strive to provide the best possible experience to our customers. Please don’t hesitate to contact PowerSchool Support with any questions.
Posted Nov 12, 2019 - 21:26 PST
Monitoring
A fix has been put in place and we are currently monitoring the situation. Thank you for your patience.
Posted Nov 12, 2019 - 15:03 PST
Investigating
We are aware of some users reporting issues when logging in to Unified Classroom. We are investigating and will update as soon as we have more information. We apologize for the inconvenience.
Posted Nov 12, 2019 - 14:30 PST
This incident affected: Unified Classroom.