Enrollment express/Ecollect Forms - Users are unable to access forms within Ecollect

Incident Report for PowerSchool Products

Resolved

The issue reported for enrollment express/E-Collect has been resolved and this incident has been closed.
Posted Oct 01, 2025 - 10:14 PDT

Monitoring

We have deployed a fix to production that has resolved the issue within enrollment express/E-Collect. We will continue to monitor the application to ensure consistent performance and critical functionality remains intact as expected.
Posted Sep 30, 2025 - 13:37 PDT

Identified

We have identified the cause for the ongoing issue within enrollment express/E-Collect and are working on deploying a fix to production. We will continue to provide regular updates on our progress.
Posted Sep 30, 2025 - 10:35 PDT

Investigating

We are investigating reports of users being unable to access forms within enrollment express/E-Collect. Our team is working diligently to mitigate the issue and will continue to provide regular updates as we progress toward a resolution.
Posted Sep 30, 2025 - 08:52 PDT
This incident affected: Enrollment Express/ECollect.