We have worked with our carrier partners to implement several solution paths to restore call traffic delivery rates. We can confirm we have seen a significant increase in successful call delivery reporting since these changes were implemented.
As a result of these improvements and resolution for many of our customers, we will update the Status Page to Resolved. We understand the telephony industry is ever-changing and that our solutions must also continually evolve to ensure the highest delivery rates remain possible.
We will continue posting updates on continued progress for this issue on that page. You can subscribe to the page to receive notifications when new updates are posted.
We strive to provide the best possible experience for our customers and would like to thank you again for your patience as we worked to resolve this.
Posted Mar 24, 2025 - 15:37 PDT
Identified
Our teams have been working to identify the underlying issue affecting some of our call traffic delivery rates for voice calls. Our carrier partners are continually updating their filtering to ensure high quality calls are being delivered over their networks. Recent adjustments by carriers have resulted in some of our large volume calls being caught in these filters.
Working with our carrier partners we have identified several solution paths to restore delivery rates and are actively working to implement these. We are seeing improvements as we deploy these changes, but have more work to undertake.
We are currently aware of an issue where some SchoolMessenger Communicate/Groupcast phone broadcasts are not being delivered to all recipients due to an ongoing problem with our telephony vendor. Resolving this issue is our top priority, and we are actively working with our vendor to address it. We will provide updates as they become available. In the meantime, we recommend utilizing multiple contact methods (phone, email, and SMS) when sending a broadcast to ensure your messages reach all intended recipients. If you need assistance setting up these contact methods, please review our support documentation below. Thank you for your understanding and patience as we work to resolve this issue. https://help.powerschool.com/t5/SchoolMessenger-Communicate/Video-Advanced-Message-Building/ta-p/511647
Posted Feb 07, 2025 - 16:01 PST
This incident affected: SchoolMessenger (SchoolMessenger Communicate).