SchoolMessenger Communicate - Issue in broadcasting SMS.

Incident Report for PowerSchool Products

Monitoring

A fix has been deployed by our Vendors to address the SMS broadcast issue within SchoolMessenger Communicate. We are currently monitoring the service to ensure stability and confirm that the issue has been fully resolved.
Posted Nov 12, 2025 - 15:00 PST

Investigating

We are investigating the report that SchoolMessenger Communicate is currently experiencing with SMS broadcast. We are actively investigating the issue and coordinating with our third-party vendor to mitigate the impact. We will continue to provide regular updates as we progress towards a resolution.
Posted Nov 12, 2025 - 13:39 PST
This incident affects: SchoolMessenger (SchoolMessenger Communicate).