Slow web response times
Incident Report for PowerSchool Products
Resolved
This incident has been resolved.
Posted Dec 02, 2024 - 07:14 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 02, 2024 - 07:07 PST
Identified
We have identified an issue that is leading to intermittent slowness in response times. Our team is addressing this issue and will update you as we progress towards resolution.
Posted Dec 02, 2024 - 06:44 PST
This incident affected: Schoology Learning (Schoology).