PowerSchool Higher Ed Applicant Tracking System Users Encountering and Error When Attempting to Log In

Incident Report for PowerSchool Products

Resolved

This incident has been resolved.
Posted Apr 27, 2026 - 14:15 PDT

Identified

The issue is identified and is impacting a subset of users. Teams are working to resolve the issue directly with impacted clients.
Posted Apr 27, 2026 - 10:13 PDT

Investigating

We are investigating reports of PowerSchool Higher Ed Applicant Tracking System Users Encountering and Error When Attempting to Log In
Posted Apr 27, 2026 - 06:25 PDT
This incident affected: HigherEd (Applicant Tracking System).