Analytics & insights - Spontaneous Dashboard Restart - 11/20/2025

Incident Report for PowerSchool Products

Resolved

The issue reported for Analytics & insights has been resolved and this incident has been closed
Posted Nov 21, 2025 - 04:59 PST

Monitoring

We experienced a brief service disruption where Customer's dashboards were restarted within Analytics & insights. The issue was quickly resolved, and normal service has been restored. We are continuing to monitor the situation to ensure everything remains stable.
Posted Nov 20, 2025 - 12:31 PST
This incident affected: Analytics & Insights.