Phone System Latency Issues
Incident Report for PowerSchool Products
Resolved
PowerSchool Support phone calls are now routing to Support Staff as expected.
Posted Aug 26, 2021 - 14:56 PDT
Identified
We are currently experiencing some latency in getting the calls to our support teams connected with an agent. Our phone provider and is working to address this latency and make the needed corrections.

If you are experiencing issues please reach out to our support team through Chat (https://help.powerschool.com/t5/Launch-Chat-Support/ct-p/LaunchChatSupport) or through our Case Portal (https://help.powerschool.com/t5/Case-Portal/ct-p/Support-CasePortal)

We will continue to provide updates as soon as possible.
Posted Aug 26, 2021 - 12:06 PDT
This incident affected: Atrieve (ADS04, ADS03, ADS05, ADS06, ADS07, ADS08, HOST02, HOST03, HOST04, HOST05, HOST06, HOST07, HOST08, HOST11, HOST12, HOST13), BusinessPlus, Cognos Reporting, eFinancePlus, Enrollment, Enrollment Express/ECollect, Naviance, Performance Matters, PowerSchool eSchoolPlus SIS, PowerSchool SIS, PowerSchool Trillium SIS, Special Programs, and Unified Talent (Professional Learning).