Analytics and Insights - ETL failures observed for subset of users.

Incident Report for PowerSchool Products

Monitoring

We are observing signs of recovery and have verified that all services are currently operating as expected. Our team will continue to closely monitor application availability to ensure consistent performance and to confirm that all critical functionality remains intact.
Posted Jul 17, 2025 - 13:25 PDT

Update

We are continuing to investigate the ETL processes and are currently assessing any potential impact on the dashboard data. We will share further updates as more information becomes available.
Posted Jul 17, 2025 - 09:24 PDT

Investigating

We are currently investigating an issue where ETL (Extract, Transform, Load) failures have been observed for a subset of customers. Our internal teams are actively analyzing the root cause and working towards a resolution. We will provide further updates as more information becomes available.
Posted Jul 17, 2025 - 08:04 PDT
This incident affects: Analytics & Insights.