eFinancePlus - Extended Maintenance for 23.10 related to the install of 23.10.12.1
Incident Report for PowerSchool Products
Resolved
If you encounter any additional access concerns with 23.10, please contact support. Thank you.
Posted Oct 16, 2024 - 08:56 PDT
Monitoring
The install of 23.10.12.1 has completed.
Posted Oct 16, 2024 - 06:57 PDT
Identified
The period of maintenance time needed to complete the install of 23.10.12.1 has been extended.
Posted Oct 16, 2024 - 05:31 PDT
This incident affected: eFinancePlus.