Powerschool SIS - Extended Change for OS Patching for PS SIS US East environment.

Incident Report for PowerSchool Products

Resolved

The issue has been mitigated by our team and the incident has been closed.
Posted Jul 14, 2025 - 09:39 PDT

Monitoring

All virtual machines hosted in the Azure East US zone have been successfully restarted, and all customer instances are now operational.
We are currently monitoring application stability to ensure continued performance.
Posted Jul 13, 2025 - 11:24 PDT

Investigating

We are investigating delays in the scheduled OS patching for the PS SIS US East environment. Services may be temporarily unavailable for some customers during this time.

Our teams are working to resolve the issue and restore full functionality. Further updates will be shared as they become available.
Posted Jul 13, 2025 - 10:15 PDT
This incident affected: PowerSchool SIS.