Atrieve - BC09/HOST12 - Application is unavailable
Incident Report for PowerSchool Products
Resolved
This incident has been resolved. Powerschool has verified that Atrieve is operational again. We apologize for the disruption.
Posted Nov 18, 2024 - 14:34 PST
Investigating
We are currently investigating reports of Atrieve being unavailable for our customers on BC09/HOST12
Posted Nov 18, 2024 - 14:24 PST
This incident affected: Atrieve (HOST12).