Special Programs is being impacted by the Microsoft Global Outage
Incident Report for PowerSchool Products
Resolved
We are pleased to inform you that the systems have been fully restored and are now back to normal operations. All services are operating as expected. We apologize for any inconvenience this may have caused and thank you for your patience and understanding during this time. If you experience any further issues, please do not hesitate to contact our support team.
Posted Jul 22, 2024 - 09:02 PDT
Update
All Special Programs customers should now have access to their Special Programs application. We are continuing to monitor for any further issues.
Posted Jul 19, 2024 - 10:06 PDT
Update
The root cause of the issue was a Windows CrowdStrike update. We will continue to provide updates until the issue has been fully resolved. We appreciate your patience while we work to resolve this issue.
Posted Jul 19, 2024 - 06:50 PDT
Monitoring
Special Programs servers are being impacted by the Microsoft Global Outage. We will provide updates here as they become available.
Posted Jul 19, 2024 - 05:10 PDT
This incident affected: Unified Classroom Special Programs.