Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 17, 2026 - 17:00 PDT
Scheduled
We have identified gaps in Enrollment data replication to Connected Intelligence affecting the SUBMISSIONRECORDS and SUBMISSIONRECORDDATAITEMS tables.
Data in the SUBMISSIONRECORDS table is incomplete for records created between August 10 and August 17, 2026. Data in the SUBMISSIONRECORDDATAITEMS table is incomplete for records created today.
To restore data completeness and ensure accuracy, Connected Intelligence will perform a reload of the affected Enrollment tables.
What to Expect This maintenance impacts Enrollment data within Connected Intelligence only. The PowerSchool Enrollment application remains available and is operating normally. Enrollment data in Connected Intelligence may appear incomplete or not fully up to date while the reload is in progress. Data will gradually repopulate in Connected Intelligence during the reload window as records are reprocessed. No customer action is required.
Posted Aug 17, 2026 - 09:20 PDT
This scheduled maintenance affected: Connected Intelligence K-12 and Connected Intelligence P20W.