Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 12, 2026 - 17:30 PDT
Scheduled
PowerSchool is releasing version UIHN_26.3.1.0 of Analytics & Insights to your server. During the maintenance window, the application will be accessible most of the time. However, customers may experience intermittent connectivity. Please pause any customizations and configuration changes to your environment during this scheduled maintenance period.
This maintenance release will be automatically deployed to all hosted Analytics & Insights customers who have opted into automated deployments (excluding ALSDE and LAUSD). Customers not participating in the automated deployment schedule will not receive this update automatically. Version UIHN_26.3.1.0 will be available to non-automated deployment customers beginning Monday, June 29, 2026. To request an upgrade, please contact our Support team.
Posted Jun 08, 2026 - 12:01 PDT
This scheduled maintenance affects: Analytics & Insights.