Performance Matters Site Loading Issues

Incident Report for PowerSchool Products

Resolved

The incident affecting access to the Performance Matters has been resolved. Please reach out to our support team if there are any additional questions.
Posted Sep 22, 2023 - 09:41 PDT

Monitoring

Our Engineering team has identified the issue, and the site's performance is presently stable, with ongoing monitoring efforts in place to ensure its continued stability.
Posted Sep 22, 2023 - 07:41 PDT

Investigating

Users are experiencing issues loading Performance Matters. We are investigating and will provide further updates.
Posted Sep 22, 2023 - 06:20 PDT
This incident affected: Performance Matters.