Professional Learning

Incident Report for PowerSchool Products

Resolved

This incident has been resolved.
Posted Apr 02, 2025 - 15:35 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 02, 2025 - 15:34 PDT

Investigating

We are aware of an issue with Ad Hoc reporting throwing an error. The team is investigating the issue and we will keep this page updated with more information as it becomes available.
Posted Apr 02, 2025 - 14:56 PDT
This incident affected: Unified Talent (Perform Enterprise, Professional Learning).