eSchoolPlus Hosted Multi-Tenant Announcement regarding the Start Page
Incident Report for PowerSchool Products
Resolved
The Start Page has been removed. Please use the direct links to eSchoolPlus and Teacher Access Center. The Account Management feature will need to be used to add new users and change passwords.
Posted Jan 10, 2025 - 09:48 PST
Identified
The Hosting Start Page - https://start.spihost.net/SPACE16/login.aspx - Has been removed.

Access to eSchoolPlus and Teacher Access Center requires the direct links to the software.

eSchoolPlus East - https://esp41pe.eschoolplus.powerschool.com/eSchoolPLUS
Teacher Access Center East - https://esp41pe.eschoolplus.powerschool.com/TAC

eSchoolPlus West - https://esp41pw.eschoolplus.powerschool.com/eSchoolPLUS
Teacher Access Center West - https://esp41pw.eschoolplus.powerschool.com/TAC

Account Management is available within eSchool. New users can be added and passwords changed.
Community article on using the Account Management in eSchool.
https://help.powerschool.com/t5/PowerSchool-eSchoolPlus-SIS/Adding-New-Users-for-Multi-Tenant-Hosting/ta-p/288829
Posted Jan 09, 2025 - 09:12 PST
This incident affected: PowerSchool eSchoolPlus SIS.