Analytics & Insights: Multiple users are unable to access Dasboards

Incident Report for PowerSchool Products

Resolved

The issue reported for Analytics & Insights has been resolved and this incident has been closed
Posted Nov 03, 2025 - 05:52 PST

Monitoring

We have deployed a fix to production that has resolved the issue in Analytics & Insights dashboards. We will continue to monitor the application to ensure consistent performance and critical functionality remains intact as expected.
Posted Oct 31, 2025 - 12:14 PDT

Investigating

We are currently investigating a service disruption affecting multiple customers in our the Prod environment. Impacted users may encounter a 503 error when accessing dashboards. Our engineering teams are actively working to identify the root cause and restore service as quickly as possible.
Posted Oct 31, 2025 - 11:58 PDT
This incident affected: Analytics & Insights.