Atrieve - AB02 - Application unavailable - web page errors

Incident Report for PowerSchool Products

Resolved

This incident has been resolved. Our teams will continue to monitor the systems as they return to full operations.
Posted Feb 19, 2025 - 15:58 PST

Investigating

We are currently investigating reports of errors when accessing Atrieve. The PowerSchool team is working to resolve this as quickly as possible.
Posted Feb 19, 2025 - 15:40 PST
This incident affected: Atrieve (HOST02).