Attendance Intervention Suite - Multiple users are reporting issues logging into Attendance Intervention Suite

Incident Report for PowerSchool Products

Resolved

The issue reported for AIS has been resolved and this incident has been closed
Posted Oct 08, 2025 - 09:31 PDT

Update

We are continuing to monitor for any further issues.
Posted Oct 08, 2025 - 07:31 PDT

Monitoring

We have deployed a fix to production that has resolved the login issue in AIS. We will continue to monitor the application to ensure consistent performance and critical functionality remains intact as expected.
Posted Oct 08, 2025 - 07:29 PDT

Investigating

We are investigating reports of users being unable to login AIS. We are working diligently to mitigate the issue being reported and will continue to provide regular updates as we progress towards a resolution.
Posted Oct 08, 2025 - 06:50 PDT
This incident affected: Attendance Intervention Suite.