PowerSchool eSchoolPlus SIS is being impacted by the Microsoft Global Outage. We will provide updates here as they become available.
Incident Report for PowerSchool Products
Resolved
Status Update: Systems Fully Recovered
We are pleased to inform you that the systems have been fully restored and are now back to normal operations. All services are operating as expected. We apologize for any inconvenience this may have caused and thank you for your patience and understanding during this time. If you experience any further issues, please do not hesitate to contact our support team
Posted Jul 22, 2024 - 08:52 PDT
Update
We are continuing to monitor for any further issues.
Posted Jul 19, 2024 - 09:37 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 19, 2024 - 08:22 PDT
Investigating
We are currently investigating this issue.
Posted Jul 19, 2024 - 05:12 PDT
This incident affected: PowerSchool eSchoolPlus SIS.