Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 07, 2025 - 17:30 PST
Scheduled
Reason For Maintenance: PowerSchool will be deploying version 24.10.2.0 of Analytics & Insights to your server. During the maintenance window, the application may be accessible, but customers may experience intermittent connectivity. Please do not make any configuration or customization updates during this scheduled maintenance period.
Who: This release will be automatically deployed to our PowerSchool-hosted SIS and Analytics & Insights customers and our hosted Analytics & Insights customers opting for automated deployments. Customers not on our automated deployment schedule will not receive this update and will need to submit a Support ticket to have the version 24.10.2.0 release to be applied to their environment.
Posted Jan 31, 2025 - 11:55 PST
This scheduled maintenance affected: Analytics & Insights.