Talkdesk Chat is down

Incident Report for PowerSchool Products

Resolved

Closing this incident as the community team have not observed any issues related to talk desk chat.
Posted Jul 02, 2025 - 06:50 PDT

Monitoring

Incoming chats are now functioning normally. The system appears to be back online, and we are continuing to monitor it closely to ensure stability.
Posted Jul 01, 2025 - 09:34 PDT

Investigating

We have identified an ongoing issue affecting Talkdesk chat functionality. Phone support and web case submissions remain fully operational. Talkdesk is aware of the issue, and we are actively collaborating with their team to implement a resolution. Further updates will be provided as they become available.
Posted Jul 01, 2025 - 06:06 PDT
This incident affected: Support Tools (Chat).