PowerSchool SIS - Few of the users are experience errors while accessing application

Incident Report for PowerSchool Products

Resolved

The issue has been resolved and we are proceeding with closing the incident
Posted Dec 10, 2025 - 23:15 PST

Update

The issue has been resolved and we are proceeding with closing the incident
Posted Dec 10, 2025 - 23:15 PST

Monitoring

We have deployed a fix to production that has resolved the issue in PowerSchool SIS. We will continue to monitor the application to ensure consistent performance and critical functionality remains intact as expected.
Posted Dec 10, 2025 - 12:49 PST

Investigating

We are investigating reports from few users getting HTTP 503 error while accessing PowerSchool SIS. We are working diligently to mitigate the issue being reported and will continue to provide regular updates as we progress towards a resolution..
Posted Dec 10, 2025 - 12:26 PST
This incident affected: PowerSchool SIS.