Atrieve - SK06 - Application currently experiencing degradation
Incident Report for PowerSchool Products
Resolved
This incident has been resolved.
Posted Sep 25, 2024 - 16:05 PDT
Monitoring
PowerSchool continues to monitor the incident that caused degradation.

We have identified a few specific areas we are working to address to minimize this incident from occurring again.
Posted Sep 24, 2024 - 09:30 PDT
Identified
The PowerSchool Team is currently investigating degradation being experienced in Atrieve at some districts.
Posted Sep 24, 2024 - 08:12 PDT
This incident affected: Atrieve (HOST06).