Document Management - Report Card Generation

Incident Report for PowerSchool Products

Resolved

This incident has been resolved.
Posted Jun 27, 2026 - 09:04 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 27, 2026 - 05:17 PDT

Identified

We have identified an issue affecting report card generation within Document Management. Our teams are actively working toward a resolution and are closely monitoring progress. We will continue to share updates as they become available.
Posted Jun 26, 2026 - 15:01 PDT
This incident affected: Document Cloud (US & Canada) (Document Management US, Document Management Canada).