Intermittent Performance Issues on NE PSSP Server
Incident Report for PowerSchool Products
Resolved
We worked diligently and full functionality was restored to Special Programs. We apologize for any inconvenience this may have caused and appreciate your patience while we worked to resolve these issues. We strive to provide the best possible experience to our customers. Please don’t hesitate to contact PowerSchool Support with any questions.
Posted Sep 30, 2020 - 16:57 PDT
Update
We were able to successfully deploy the update to the Eastern region servers and are continuing to monitor for any events. Thank you for your patience while we continued to work on a fix for this issue and we apologize for any inconvenience this may have caused. PowerSchool is committed to delivering top tier performance and will continue to monitor things to ensure we meet that commitment.
Posted Sep 28, 2020 - 08:25 PDT
Monitoring
Our team has successfully created a fix that will be released tonight. While we are applying the fix, Special Programs may be unavailable for customers that are in the eastern region. Specifically, if you are using Special Programs on the North East, Midwest, or Southeast instances.

The maintenance window will start on September 25, 2020, at 9:30 PM EDT to September 26, 2020, at 5:00 AM EDT.

To confirm which instance you are on, please look at the URL while you are in Special Programs. For example, the North East instance has the following URL https://ne.specialeducation.powerschool.com which uses “NE” to identify the region. The same can be used to identify the Midwest and Southeast as “MW” and “SE”.

Thank you for your patience while we continued to work on a fix for this issue and we apologize for any inconvenience this may have caused. PowerSchool is committed to delivering top tier performance and will continue to monitor things to ensure we meet that commitment.
Posted Sep 25, 2020 - 13:10 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 23, 2020 - 13:08 PDT
Update
We have identified the issue and are currently implementing a fix. We apologize for the inconvenience this may have caused and we are working diligently to restore full system functionality. We will provide updates as they become available.
Posted Sep 23, 2020 - 13:07 PDT
Investigating
We are aware of intermittent performance issues with PowerSchool Special Programs affecting some of our customers.

Upon discovery, PowerSchool immediately escalated the issue to our server provider and partner, Microsoft Azure. As we continue to work to find a resolution, we are performing server upgrades to mitigate impact to Administrators and staff using Special Programs throughout the day.

We will provide additional updates here as they become available.
Posted Sep 22, 2020 - 15:01 PDT
This incident affected: Unified Classroom Special Programs.