The issue reported for the eCollect forms, which was preventing some users from editing existing forms and creating new ones, has been resolved, and the incident has been closed.
Posted Jul 02, 2025 - 07:27 PDT
Monitoring
The issue impacting the eCollect product has been resolved. Deployment to affected customers is now complete, and full functionality has been restored. We will continue to monitor the system to ensure stability.
Posted Jul 01, 2025 - 13:57 PDT
Investigating
We are currently investigating an issue impacting the eCollect product, which is preventing some users from editing existing forms and creating new ones. Our technical teams are actively working to restore full functionality as quickly as possible. We appreciate your understanding and will provide further updates as they become available
Posted Jul 01, 2025 - 09:57 PDT
Monitoring
We have deployed a fix to production that has resolved the reports of Ecollect Form Submission and Access Issues. We will continue to monitor the application availability to ensure consistent performance and critical functionality remains intact as expected.
Posted Jun 30, 2025 - 13:29 PDT
Identified
Our engineering team has identified the issue impacting Ecollect form submissions. The team is currently in the process of implementing a workaround that will mitigate the issue. We will continue to provide regular updates until full service is restored.
Posted Jun 25, 2025 - 12:50 PDT
Investigating
We are investigating reports from multiple hosted customers experiencing issues with form submission and application access on the Ecollect & Enrollment Express platform. We are working diligently to mitigate the issue being reported and will continue to provide regular updates as we progress towards a resolution.
Posted Jun 25, 2025 - 11:37 PDT
This incident affected: Enrollment Express/ECollect.