Perform Enterprise users unable to Share Observations
Incident Report for PowerSchool Products
Resolved
The issue has been resolved and users should not have any additional issues sharing observations. We apologize for any inconvenience users experienced.
Posted Jun 28, 2022 - 04:06 PDT
Identified
The issue causing users to not be able to share observations in Perform Enterprise has been identified. The engineering team is currently determining the path to resolve for all customers. We will update further when this is resolved for all districts.
Posted Jun 27, 2022 - 16:24 PDT
Investigating
Our engineering team is currently investigating an issue in Perform Enterprise where Observations that are complete may error when the user attempts to Share the observation with the end user. This page will be updated until the issue is resolved.
Posted Jun 27, 2022 - 14:44 PDT
This incident affected: Perform Enterprise & Professional Learning.