The issue reported for Users experiencing errors during submission within Ecollect Forms and Enrollment Express has been resolved and this incident has been closed.
Posted Aug 11, 2025 - 05:45 PDT
Monitoring
The issue affecting form submissions in Ecollect Forms and Enrollment Express has been mitigated. We are currently monitoring system performance to ensure continued stability.
Posted Aug 10, 2025 - 10:46 PDT
Update
We have identified the issue affecting form submissions in Ecollect Forms and Enrollment Express. Remediation efforts are in progress to restore full service.
Posted Aug 10, 2025 - 09:44 PDT
Investigating
We’re investigating an issue affecting form submissions in Ecollect Forms and Enrollment Express. Users may experience errors during submission. Updates will be provided as more information becomes available.
Posted Aug 10, 2025 - 09:27 PDT
This incident affected: Enrollment Express/ECollect.