A fix has been successfully deployed to the production environment to address the issue impacting the Performance Matters assessment. Following the deployment, we’ve observed full recovery from several affected customers. Based on these results, we are proceeding with the formal closure of the incident.
Posted Nov 04, 2025 - 05:17 PST
Update
We have identified a resolution for the ongoing issue in Performance Matters and are working to deploy a fix to production overnight. We will continue to provide regular updates on our progress.
Posted Nov 03, 2025 - 12:44 PST
Update
We have identified a resolution for the ongoing issue in Performance Matters and are working on deploying a fix to production. We will continue to provide regular updates on our progress.
Posted Nov 03, 2025 - 10:14 PST
Identified
We have identified the cause for the ongoing issue in Performance Matters and are working to mitigate the issue. We will continue to provide regular updates as it becomes available.
Posted Nov 03, 2025 - 06:30 PST
Investigating
We are investigating reports of images not showing in Assessments within Performance Matters. We are working diligently to mitigate the issue being reported and will continue to provide regular updates as we progress towards a resolution.