We are no longer experiencing delayed SMS deliveries and SMS Failures within SchoolMessenger Communicate. This incident is resolved.
Posted Aug 28, 2025 - 15:59 PDT
Monitoring
We are observing a significant reduction in SMS delivery delays and failures across multiple U.S. networks. Based on current metrics, the issue appears to be stabilizing. We continue to monitor the situation closely in coordination with our vendor and will provide updates as needed.
Posted Aug 28, 2025 - 15:06 PDT
Identified
We have received confirmation from External Vendor that a resolution has been identified for the ongoing issue within SchoolMessenger Communicate. We are in coordination with Vendor, and the Mitigation efforts are currently in progress, and We will continue to provide regular updates on our progress.
Posted Aug 28, 2025 - 14:25 PDT
Investigating
We are investigating the reports of Delayed SMS deliveries and SMS Failures within SchoolMessenger Communicate. We are working diligently to mitigate the issue being reported and will continue to provide regular updates as we progress towards a resolution.
Posted Aug 28, 2025 - 13:04 PDT
This incident affected: SchoolMessenger (SchoolMessenger Communicate).