Intermittent Errors When Navigating Schoology

Incident Report for PowerSchool Products

Resolved

The issue has been resolved, and users should now be able to access and navigate the platform normally.

We apologize for any inconvenience this may have caused and appreciate your patience. If you continue to experience any issues, please contact PowerSchool Support for assistance.
Posted Sep 03, 2026 - 07:46 PDT

Monitoring

We are aware that some users experienced issues navigating within to Schoology earlier today. The service has now recovered, and users should be able to access the platform normally.

Our team will continue to monitor system performance to ensure ongoing stability. We apologize for any inconvenience this may have caused and appreciate your patience.
Posted Sep 03, 2026 - 07:03 PDT
This incident affected: Schoology Learning (Schoology).