SchoolMessenger Communicate/Safe Arrival Canada problems with inbound phone lines

Incident Report for PowerSchool Products

Resolved

We have successfully resolved this issue at this time. We strive to provide the best possible experience for our customers and would like to thank you again for your patience as we worked to resolve this.
Posted Mar 21, 2025 - 08:49 PDT

Investigating

We are aware of an issue with where some calls made to inbound phone lines for SchoolMessenger Communicate/SafeArrival in Canada are presenting a busy signal. We are working to assess the situation and will continue to provide you with regular updates as they become available. We appreciate your patience while we work to resolve this issue.
Posted Mar 20, 2025 - 11:50 PDT
This incident affected: SchoolMessenger (SchoolMessenger Communicate).