Multiple products are facing intermittent issue due to an IMPERVA Outage.

Incident Report for PowerSchool Products

Resolved

The issue reported for Multiple products facing intermittent issue due to Imperva Outage has been resolved and this incident has been closed.
Posted May 14, 2025 - 11:26 PDT

Monitoring

We have noted that the systems have stabilized following the IMPERVA outage. We will continue to monitor the application to ensure consistent performance and that critical functionality remains intact.
Posted May 14, 2025 - 10:31 PDT

Investigating

We are investigating reports of IMPERVA issue within multiple products and we are diligently working to mitigate the issue being reported and will continue to provide regular updates as we progress towards a resolution
Posted May 14, 2025 - 09:58 PDT
This incident affected: Analytics & Insights, BusinessPlus, Cognos Reporting, eFinancePlus, Enrollment, Enrollment Express/ECollect, PowerSchool eSchoolPlus SIS, PowerSchool SIS, Special Programs, Atrieve (HOST02, HOST03, HOST04, HOST05, HOST06, HOST07, HOST08, HOST11, HOST12, HOST13, HOST31, HOST32, HOST33, HOST34, HOST35, HOST36), and Unified Talent (SchoolSpring Job Board, SmartFind Express (Absence Management)).