Schoology Learning - Site Loading Issues

Incident Report for PowerSchool Products

Resolved

The issue has been resolved and all systems are fully operational again.
Posted Apr 09, 2025 - 07:19 PDT

Update

A fix has been implemented and we are continuing to monitor site performance. Thank you for your patience.
Posted Apr 09, 2025 - 07:12 PDT

Monitoring

A fix has been implemented and we are monitoring results.
Posted Apr 09, 2025 - 06:41 PDT

Investigating

Some users may experience intermittent errors when navigating in Schoology Learning. Re-loading the page may resolve the issue. We are investigating and will provide further updates.
Posted Apr 09, 2025 - 05:55 PDT
This incident affected: Schoology Learning (Schoology).