efinancePlus- EAC module outage for all efinancePlus users using version 23.10

Incident Report for PowerSchool Products

Resolved

The Issue reported for EAC module outage for all efinancePlus users using version 23.10 has been resolved and this incident has been closed.
Posted May 05, 2025 - 07:48 PDT

Investigating

We are investigating reports of eFinancePlus Hosted Customers are not able to access Employee Access Center (EAC), they are receiving an error '404 - File or Directory is not found within eFinancePlus. We are working diligently to mitigate the issue being reported and will continue to provide regular updates as we progress towards a resolution.
Posted May 05, 2025 - 06:42 PDT
This incident affected: eFinancePlus.