The reports from Customers encountering issues contacting support through Phone and Chat has been resolved and this incident has been closed.
Posted Jun 10, 2025 - 09:46 PDT
Monitoring
We have deployed a fix to production that has resolved the reports of Customers encountering issues contacting support through Phone and Chat. We will continue to monitor the application availability to ensure consistent performance and critical functionality remains intact as expected.
Posted Jun 10, 2025 - 09:30 PDT
Identified
We have identified a resolution for the ongoing reports of Customers encountering issue contacting support through phone and chat and We are working on deploying a fix to production. We will continue to provide regular updates on our progress.
Posted Jun 10, 2025 - 09:27 PDT
Investigating
We are investigating the reports of Customers encountering issues contacting support through Phone and Chat. We are working diligently to mitigate the issue being reported and will continue to provide regular updates as we progress towards a resolution.
Posted Jun 10, 2025 - 08:36 PDT
This incident affected: Support Tools (Chat, Phone Support).