Atrieve - BC09 - application not available
Incident Report for PowerSchool Products
Resolved
We have identified the cause of the incident and all systems have returned to normal. The PowerSchool team will continue to monitor.
Posted Sep 25, 2024 - 16:07 PDT
Investigating
We are currently investigating an issue that is impacting endusers' ability to access Atrieve.
Posted Sep 25, 2024 - 15:56 PDT
This incident affected: Atrieve (HOST12).