The issue reported for SchoolMessenger Communicate has been resolved and this incident has been closed.
Posted Jan 19, 2026 - 06:12 PST
Monitoring
We have deployed a fix to production that has resolved the issue in SchoolMessenger Communicate. We will continue to monitor the application to ensure consistent performance and critical functionality remains intact as expected.
Posted Jan 16, 2026 - 07:06 PST
Identified
We have identified the cause for the ongoing issue in SchoolMessenger Communicate and are working on deploying a fix to production. We will continue to provide regular updates on our progress.
Posted Jan 16, 2026 - 05:50 PST
Investigating
We are investigating reports of Email broadcast delays for multiple customers within SchoolMessenger Communicate caused due to an issue on one of our vendors. We are coordinating with the vendor to mitigate the issue being reported and will continue to provide regular updates as we progress towards a resolution..
Posted Jan 15, 2026 - 11:08 PST
This incident affected: SchoolMessenger (SchoolMessenger Communicate).