Intermittent Connectivity Issues
Incident Report for PowerSchool Products
Resolved
Connectivity has been restored. If you continue to experience any issues, please reach out to PowerSchool Support via phone, web, or chat through our PowerSchool Community
Posted Aug 30, 2020 - 09:36 PDT
Monitoring
We have identified that an outage with an internet carrier impacted connectivity to some of our services for customers. We are now seeing connectivity restored. While we continue to monitor this issue, if you continue to experience any issues, please reach out to PowerSchool Support via phone, web, or chat through our PowerSchool Community
Posted Aug 30, 2020 - 08:07 PDT
This incident affected: BusinessPlus, eFinancePlus, Enrollment, PowerSchool Learning, PowerSchool SIS, and PowerSchool Special Programs.