PowerSchool eSchoolPlus SIS Users Encountering Errors When Logging Into eSchoolPlus

Incident Report for PowerSchool Products

Resolved

This incident has been resolved.
Posted Apr 24, 2026 - 12:25 PDT

Monitoring

A fix has been implemented and we are monitoring to ensure continued stability.
Posted Apr 24, 2026 - 11:20 PDT

Identified

Teams are seeing some improvement but are seeing intermittent errors. We are continuing to work to implement a resolution.
Posted Apr 24, 2026 - 08:54 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 24, 2026 - 08:46 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 24, 2026 - 08:18 PDT

Update

We are continuing to investigate the errors being encountered and are diligently working to restore access.
Posted Apr 24, 2026 - 07:56 PDT

Update

We are continuing to investigate this issue.
Posted Apr 24, 2026 - 06:45 PDT

Investigating

We are investigating reports of PowerSchool eSchoolPlus SIS users encountering 502 Bad Gateway errors when attempting to log into the product.
Posted Apr 24, 2026 - 06:44 PDT
This incident affected: PowerSchool eSchoolPlus SIS.