Unified Classroom Class Pages and PowerSchool Learning
Incident Report for PowerSchool Products
Resolved
We worked diligently and full functionality was restored to Learning and Class Pages. We apologize for any inconvenience this may have caused and appreciate your patience while we worked to resolve these issues. We strive to provide the best possible experience to our customers. Please don’t hesitate to contact PowerSchool Support with any questions.
Posted Nov 04, 2019 - 15:38 PST
Update
The information has finished propagating. We will continue to monitor the situation. Thank you for your patience while we worked to address the issue. We apologize for the inconvenience.
Posted Nov 04, 2019 - 08:32 PST
Monitoring
A fix has been put in place which is taking some time to propagate information. We will update as we have a more information.
Posted Nov 04, 2019 - 07:30 PST
Investigating
We are still seeing the issue occurring and are continuing investigation.
Posted Nov 04, 2019 - 06:35 PST
Monitoring
We have identified the issue, applied a fix, and are currently monitoring the situation.
Posted Nov 04, 2019 - 06:12 PST
Investigating
We are aware and currently investigating the reports of PowerSchool Learning users not seeing content and data update after saving. Updates will be provided as we have more information. We apologize for any inconvenience.
Posted Nov 04, 2019 - 04:35 PST
This incident affected: PowerSchool Learning and Unified Classroom.